IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
About scripting the AI
ʇɐuʞɐʇǝp
post 15 Mar 2016, 16:16
Post #1



Group Icon

Group: Members
Posts: 6
Joined: 15 March 2016
From: Within the Tokoyami
Member No.: 12684
Hi :3



Hey there, long time no see. Back in March of 2014, I edited the AI scripting a bit for version 2.0 of the mod so that the AI could build its new units. Very recently, I came back to the game, and as a result, modding for personal use, but I figured out how to enable the AI to build the new buildings and use most of the new upgrades along with all of the new units. If you guys would happen to still require aid in this area, or still have any interest in this at all, I could potentially assist. Let me know if you'd be interested, and as always, it's good to see you all still kicking smile.gif





Sincerely,
ʇɐuʞɐʇǝp

This post has been edited by ʇɐuʞɐʇǝp: 15 Mar 2016, 16:45


--------------------
*To be updated*
Go to the top of the page
 
+Quote Post
MyDude25
post 17 Mar 2016, 7:05
Post #2



Group Icon

Group: Project Leader
Posts: 164
Joined: 25 March 2010
Member No.: 881



Hey, welcome back tankated and yep, we're still badly looking for a dedicated AI scripter; At most, we're currently looking for someone that could do an AI patch for the current version 3 release.

As for version 4.0 currently in development, there were ALOT of changes that practically made it incompatible with the version 3.0 release so, in that sense, the AI might need a semi-complete rewrite.

This post has been edited by Kris: 17 Mar 2016, 7:10


--------------------
Sup guiyz
Go to the top of the page
 
+Quote Post
ʇɐuʞɐʇǝp
post 18 Mar 2016, 13:32
Post #3



Group Icon

Group: Members
Posts: 6
Joined: 15 March 2016
From: Within the Tokoyami
Member No.: 12684
Hi :3



QUOTE (Kris @ 17 Mar 2016, 1:05) *
Hey, welcome back tankated and yep, we're still badly looking for a dedicated AI scripter; At most, we're currently looking for someone that could do an AI patch for the current version 3 release.

As for version 4.0 currently in development, there were ALOT of changes that practically made it incompatible with the version 3.0 release so, in that sense, the AI might need a semi-complete rewrite.


I see. At the moment, I have achieved getting the Laser General and Vanilla USA to use all of their upgrades(except for the Crusader's machinegun, some drones here and there, and the patriot rods) and their tech center, along with all of their units. I have been having some issues with getting GLA to build its prison and radar station along with it's other buildings, since it ends up building those and an arms dealer/barracks/supply stash, a few defenses, and then it's done, but other times will build everything. I'm still relatively new to this, but I'll see what I can do :3

This post has been edited by ʇɐuʞɐʇǝp: 18 Mar 2016, 14:15


--------------------
*To be updated*
Go to the top of the page
 
+Quote Post
ʇɐuʞɐʇǝp
post 22 Mar 2016, 14:50
Post #4



Group Icon

Group: Members
Posts: 6
Joined: 15 March 2016
From: Within the Tokoyami
Member No.: 12684
Hi :3



I figured out how the Chinese ai broke. Basically, it couldn't handle the fact that you made the Gattling cannon require both a propaganda center and a research center, and therefore simply stopped building when it couldn't get past not being able to build a Gattling cannon right away, thus breaking the entire process. When I changed the prerequisites back to the reactor, the ai worked fine. I'm going to have to figure out how to address it directly, but at this point, the Tank General and USA(and its subfactions) build all of the new stuff), and use all of the new upgrades.

I'll let you know when I finish ;^)

This post has been edited by ʇɐuʞɐʇǝp: 23 Mar 2016, 13:44


--------------------
*To be updated*
Go to the top of the page
 
+Quote Post
ʇɐuʞɐʇǝp
post 9 Apr 2016, 2:16
Post #5



Group Icon

Group: Members
Posts: 6
Joined: 15 March 2016
From: Within the Tokoyami
Member No.: 12684
Hi :3



AI is basically done, just sorting out a minor issue with the Superweapon General crashing mid-game. Also no isp atm...will keep you updated smile.gif


--------------------
*To be updated*
Go to the top of the page
 
+Quote Post
MyDude25
post 9 Apr 2016, 4:57
Post #6



Group Icon

Group: Project Leader
Posts: 164
Joined: 25 March 2010
Member No.: 881



Glad you're taking your time to create an AI patch for the current release (version 3.0) , we really appreciate it.

As for the internal 4.0 version, will recontact you once i have a stable build for it and if you happen to have skype or something, please do PM me your ID so i can then give you direct access to the current dev.

This post has been edited by Kris: 9 Apr 2016, 5:04


--------------------
Sup guiyz
Go to the top of the page
 
+Quote Post
ʇɐuʞɐʇǝp
post 13 Apr 2016, 20:45
Post #7



Group Icon

Group: Members
Posts: 6
Joined: 15 March 2016
From: Within the Tokoyami
Member No.: 12684
Hi :3



QUOTE (Kris @ 8 Apr 2016, 22:57) *
Glad you're taking your time to create an AI patch for the current release (version 3.0) , we really appreciate it.

As for the internal 4.0 version, will recontact you once i have a stable build for it and if you happen to have skype or something, please do PM me your ID so i can then give you direct access to the current dev.


I finally got a new isp \o/

In the meantime, check your inbox on here ;o

I've taken this time to make the Easy AI a bit more respectable, and I've been tweaking everything in general.

This post has been edited by ʇɐuʞɐʇǝp: 13 Apr 2016, 20:53


--------------------
*To be updated*
Go to the top of the page
 
+Quote Post
mouarf
post 1 Nov 2016, 17:03
Post #8



Group Icon

Group: New Members
Posts: 2
Joined: 23 October 2016
Member No.: 13275



Hi,

Is this AI patch available somewhere ? I'd like to give it a try.

Regards
Go to the top of the page
 
+Quote Post
mouarf
post 14 Dec 2016, 10:20
Post #9



Group Icon

Group: New Members
Posts: 2
Joined: 23 October 2016
Member No.: 13275



Please consider releasing the script as a christmas present to community :-)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 11 December 2018 - 0:45