IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Connection errors, Disconnect when someone joins on lan
hmulder66
post 18 Apr 2017, 12:31
Post #1



Group Icon

Group: New Members
Posts: 4
Joined: 18 April 2017
Member No.: 15053



We recently started playing this awesome mod with some friends and everything worked very fine at first.
We just used tunggle to connect and we all could. Sadly there were some issues later.

At first my brother could join a server but would disconnect upon starting the network game (stuck in loading screen) and we would get the usual disconnection error.
But generally by switching server host this problem ended. However now we more frequently have another issue. A lot of times when we try to get a server running it works under one circumstance. As long as there is only one person on our lan network there are no issues. but if my brother joins or the brother of a friend of mine. we only see eachother, Presumably through LAN. This might however be an issue with the tunggle or what we now use: evolve. However it seems that this bug only happens every now and then.

I was wondering if shockwave had any issues allowing multiple people on a single lan. If there is another option I would love to hear it. We all LOVE this mod and like to play it together. I hope you can figure out the problem. I also contacted the guys at evolve in case they had any idea about the matter.

Thanks in advance,

Harold Mulder
Go to the top of the page
 
+Quote Post
Maelstrom
post 18 Apr 2017, 12:55
Post #2


Ze Big Cheese
Group Icon

Group: Dev. Team
Posts: 401
Joined: 19 May 2013
Member No.: 9941



Hello and welcome to the forums !

You mentionned using Tunggle. One option is to try SWR.net instead.
- Click the red dot on the launcher, and once you have a player counter, launch the game.
- Once it's launched, go to options, ensure that your LAN IP is 10.something.something.something. If not, quit and restart everything (might take a few seconds after game has exited for swr.net to close
- Once everyone has a correct IP, go to network > swr.net. Now you should see your friends, and possibly other players wink.gif

See if that fixes your connexion issues.


--------------------

My Soundcloud profile: right here
Go to the top of the page
 
+Quote Post
hmulder66
post 18 Apr 2017, 15:37
Post #3



Group Icon

Group: New Members
Posts: 4
Joined: 18 April 2017
Member No.: 15053



QUOTE (Maelstrom @ 18 Apr 2017, 13:55) *
Hello and welcome to the forums !

You mentionned using Tunggle. One option is to try SWR.net instead.
- Click the red dot on the launcher, and once you have a player counter, launch the game.
- Once it's launched, go to options, ensure that your LAN IP is 10.something.something.something. If not, quit and restart everything (might take a few seconds after game has exited for swr.net to close
- Once everyone has a correct IP, go to network > swr.net. Now you should see your friends, and possibly other players wink.gif

See if that fixes your connexion issues.


We have done this before and it has worked. However only when still using evolve. Once we exited evolve connection was lost. Sadly though it only worked one of the times we tried for us.

Thanks in advance,

Harold Mulder
Go to the top of the page
 
+Quote Post
hmulder66
post 19 Apr 2017, 8:26
Post #4



Group Icon

Group: New Members
Posts: 4
Joined: 18 April 2017
Member No.: 15053



QUOTE (hmulder66 @ 18 Apr 2017, 16:37) *
We have done this before and it has worked. However only when still using evolve. Once we exited evolve connection was lost. Sadly though it only worked one of the times we tried for us.

Thanks in advance,

Harold Mulder


Yesterday we got swr.net to work on its own however still had issues with my brother freezing on the loading screen. Also we had some issues with syncronisation errors. These might be due to our internet though. biggrin.gif Also we did manage to play one close to full game before lose of sync. Hope this helps.

Thanks in advance,

Harold Mulder

P.S: battle busses are awesome!
Go to the top of the page
 
+Quote Post
Maelstrom
post 19 Apr 2017, 9:47
Post #5


Ze Big Cheese
Group Icon

Group: Dev. Team
Posts: 401
Joined: 19 May 2013
Member No.: 9941



QUOTE (hmulder66 @ 19 Apr 2017, 9:26) *
Yesterday we got swr.net to work on its own however still had issues with my brother freezing on the loading screen. Also we had some issues with syncronisation errors. These might be due to our internet though. biggrin.gif Also we did manage to play one close to full game before lose of sync. Hope this helps.

Thanks in advance,

Harold Mulder

P.S: battle busses are awesome!

Mismatches and desync can also be due to the aging engine, and sadly can't be fixed since we don't have the game's source engine. Keep in mind that the game is from 2003, and IP stuff has since evolved.

Battle busses are good, but they are nothing compared to Recoilless Riflemen wink.gif


--------------------

My Soundcloud profile: right here
Go to the top of the page
 
+Quote Post
hmulder66
post 19 Apr 2017, 13:41
Post #6



Group Icon

Group: New Members
Posts: 4
Joined: 18 April 2017
Member No.: 15053



QUOTE (Maelstrom @ 19 Apr 2017, 10:47) *
Mismatches and desync can also be due to the aging engine, and sadly can't be fixed since we don't have the game's source engine. Keep in mind that the game is from 2003, and IP stuff has since evolved.

Battle busses are good, but they are nothing compared to Recoilless Riflemen wink.gif


Sad to hear but of course understandable. Any chance we can improve it at least a bit? Since at this point we seem to get sync errors close to every game. I understand though that this might be out of your control but am still hoping for the best. Also any chance you guys will create your own RTS one day? might be interested to join in as I've been tooling around with programming for a bit now.

Getting of topic again I know. biggrin.gif
I think it would be an incredibly usable experience though.

Thanks for the help,

Harold Mulder.
Go to the top of the page
 
+Quote Post
Maelstrom
post 19 Apr 2017, 17:13
Post #7


Ze Big Cheese
Group Icon

Group: Dev. Team
Posts: 401
Joined: 19 May 2013
Member No.: 9941



QUOTE (hmulder66 @ 19 Apr 2017, 14:41) *
Sad to hear but of course understandable. Any chance we can improve it at least a bit? Since at this point we seem to get sync errors close to every game. I understand though that this might be out of your control but am still hoping for the best. Also any chance you guys will create your own RTS one day? might be interested to join in as I've been tooling around with programming for a bit now.


Getting better chances to avoid mismatches are linked directly to game engine. So not much chances, sorry.

As for a new, RTS, for now the priority is to finish Rise of the Reds 1.87, make 2.0, and after this, the team did not say what they are going to do. They will probably do so when they are at that point wink.gif


--------------------

My Soundcloud profile: right here
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 24 June 2017 - 9:40