Help - Search - Members - Calendar
Full Version: Problems with shockwave
SWR Productions Forum > SWR Projects > ShockWave > ShockWave Support
Curious_Curiouser
I am having some trouble with shockwave and would appreciate any support. I get a "serious error" message when I try to run it, and it will not start. I have patched it to the required version, I have followed the proper installation, and I have tried uninstalling and reinstalling Generals and Zero Hour. None of these have worked so far. I am running windows vista and have the UK edition. Please help!
Pickysaurus
Did you run the installers as an administrator?
Curious_Curiouser
QUOTE (Pickysaurus @ 30 Jan 2010, 10:55) *
Did you run the installers as an administrator?


I am the admin on my computer
Shock
Do you have the original games or the first decade?

What exactly does the error msg say?
Curious_Curiouser
Original games, and yes I did install the patch. The error says that a serious error has occured, and gives no useful information. It only comes when I try and run shockwave; Zero Hour runs fine.
Alias
You're running Vista, so you NEED to make sure you are running the launcher as admin. UAC really messes up in this respect.
Curious_Curiouser
Okay, I'll uninstall shockwave and reinstall as an admin manually just to be sure., thanks. I'll reply if it doesn't work.
Alias
The install is fine. It's when you run the Shockwave launcher you need to make sure.
Curious_Curiouser
Nope, doesn't work even if I run the launcher as an admin.
IonCharge
Check you crashdump.txt file in your ZH documents in my documents. Tells you what the problem was
Curious_Curiouser
QUOTE (IonCharge @ 31 Jan 2010, 12:53) *
Check you crashdump.txt file in your ZH documents in my documents. Tells you what the problem was


No crashdump.txt file, but the releasecrashinfo text document states:

Release Crash at Sun Jan 31 17:00:45 2010
; Reason Error parsing INI file 'Data\INI\Object\airforcegeneral.ini' (Line: 'Object AirF_AmericaTankAvenger')


Last error:


Current stack:


Anyone know how to fix this?
Pickysaurus
reinstall?
Curious_Curiouser
QUOTE (Pickysaurus @ 1 Feb 2010, 9:04) *
reinstall?


Tried it. Thrice. And reinstalling zero hour and installing it again.
Pickysaurus
Did you completely remove the ZH folder when uninstalling?
n5p29
there must be any conflicting mods installed. like picky said, clean the directory after unistalling then install them back.
Curious_Curiouser
I have no other mods, but will try to be extra thorough this time in removing the ZH folder.
wb21
And if it fails, it might be registry entries that could still be left during uninstallation, which may interfere with the ZH installation. Try using a registry cleaner (like CCleaner), then reinstall.
Curious_Curiouser
Where do you get CCleaner?
Pickysaurus
Google CCleaner, but I think it's http://CCleaner.com
Shock
technically registry should not be the problem if you can launch ZH but not Shockwave as the latter has nothing to do with the registry.

It is a file error problem presumably caused by not removing your Program files/EA games/Zero Hour folder
Stubbjax
I only ever got this problem when my Zero Hour wasn't patched to 1.04. I think you should double check to see if it's patched, just to be sure.
Pickysaurus
Could be a corrupt installation?
Do you get any "missing file" errors while installing or anything?

And are you disks scratched up?
Curious_Curiouser
No errors while installing, I used the link to the patch in the shockwavel installation folder.
Curious_Curiouser
Does anyone know what's wrong? Please help, I've tried everything here!
lunagron
This happened to me once. I switched all the .gib files to .big files.
Curious_Curiouser
I'm sorry, I'm not entirley sure how to do that. Can you please give me some instructions?
Nameless1
To change the file type from .gib to .big you first need to make sure you can see the file extensions by going Tools, Folder Options, under the View tab, scroll down until you see Hide extensions for known file types and untick the box. Then hit OK. Now all you need to do is rename the files changing only the .gib to .big.
Curious_Curiouser
I have done this, run the launcher as an admin, and then it shows the error message, and the files revert to .gib files. Does anyone know how I can make them stay as .big?
Alias
Once you have renamed them to big files, don't use the launcher. Run the game directly from the Zero Hour shortcut and the mod should work.
Curious_Curiouser
I've managed to get it working, thank you!
agw97
QUOTE (Alias @ 6 Feb 2010, 23:00) *
Once you have renamed them to big files, don't use the launcher. Run the game directly from the Zero Hour shortcut and the mod should work.


I did changing the .gib files to .big files, then I proceeded to run the game directly from the ZH shortcut but it still doesn't work. It keeps showing the 'serious error' message again everytime. Please help.
curi0
QUOTE (agw97 @ 19 Jan 2016, 20:31) *
I did changing the .gib files to .big files, then I proceeded to run the game directly from the ZH shortcut but it still doesn't work. It keeps showing the 'serious error' message again everytime. Please help.


This is a list of *.big files that belong to vanilla Zero Hour + Shockwave. If you see any other *.big files that are different from the list, then they are part of other installed mods and you need to rename them to *.gib or something, or move them out of Zero Hour installation folder to prevent the error. After that, just launch the game from generals.exe shortcut (not from Shockwave launcher).

CODE
!!0ShwPtchIcon.big
!!Shw_cicons.big
!0Shwpatch.big
!Shw_challenge.big
!Shw_content.big
!Shw_ini.big
!Shw_maps.big
!Shw_scripts.big
AudioEnglishZH.big
AudioZH.big
EnglishZH.big
GensecZH.big
INIZH.big
MapsZH.big
Music.big
MusicZH.big
PatchZH.big
ShadersZH.big
SpeechEnglishZH.big
SpeechZH.big
TerrainZH.big
TexturesZH.big
W3DEnglishZH.big
W3DZH.big
WindowZH.big
Crossfire97
QUOTE (curi0 @ 21 Jan 2016, 3:19) *
This is a list of *.big files that belong to vanilla Zero Hour + Shockwave. If you see any other *.big files that are different from the list, then they are part of other installed mods and you need to rename them to *.gib or something, or move them out of Zero Hour installation folder to prevent the error. After that, just launch the game from generals.exe shortcut (not from Shockwave launcher).

CODE
!!0ShwPtchIcon.big
!!Shw_cicons.big
!0Shwpatch.big
!Shw_challenge.big
!Shw_content.big
!Shw_ini.big
!Shw_maps.big
!Shw_scripts.big
AudioEnglishZH.big
AudioZH.big
EnglishZH.big
GensecZH.big
INIZH.big
MapsZH.big
Music.big
MusicZH.big
PatchZH.big <--------
ShadersZH.big
SpeechEnglishZH.big
SpeechZH.big
TerrainZH.big
TexturesZH.big
W3DEnglishZH.big
W3DZH.big
WindowZH.big


Hi sorry to be a pain but I looked at all and I noticed I don't have one of them and that is PatchZH.big and I think this isn't allowing me to open my game because of it is there something I can do to fix?
Zeke
QUOTE (Crossfire97 @ 17 Feb 2016, 21:27) *
Hi sorry to be a pain but I looked at all and I noticed I don't have one of them and that is PatchZH.big and I think this isn't allowing me to open my game because of it is there something I can do to fix?


This probably means that you didn't patch your ZH to version 1.04

Check this guide for more info: https://docs.google.com/document/d/1cqTHHvD...dit?usp=sharing
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.