Help - Search - Members - Calendar
Full Version: Installation and Launcher issues.
SWR Productions Forum > SWR Projects > ShockWave > ShockWave Support
Pages: 1, 2
Alias
For ease of solving as well as easy access to previous solutions/what has worked for other people please use this thread for any issues you have with the installation or launching process.

Usually the main problem with the installation procedure is not running the installer with admin privileges, please make sure you do so or some/all files will not copy properly.

Other issues include having other non-compatible mods installed (all SWR mods are cross compatible, along with most mods that use a launcher, if you are unsure, uninstall them), or having an old version of Shockwave installed. Please uninstall 0.95, 0.951 or 1.0 prior to installing 1.1.

1.1 Note: the 1.1 launcher has been optimised so hopefully there should be fewer problems, this is not a guarantee, but you should have less problems with 1.1 then you had with 1.0 (if you had any to begin with).

Installation checklist:
- A completely clean install of Zero Hour (a fresh or repair install is usually advised for most users)
- Patch Zero Hour to 1.04 (if you're on the First Decade this is not necessary).
- Make sure your Zero Hour folder is not set to read only.
- Run the install program as admin
- Make sure the path chosen by the installer is correct
- If the installer hangs, wait for it. The main content file is large so it takes some time to copy.

Launching checklist:
- Installation was successful (.gib files in the Zero Hour folder, etc)
- No conflicting mods installed
- Run the respective launcher link as admin
- A good way to check if the launcher should be working is to launch the vanilla Zero Hour executable, if you have issues with that or another mod is activated when doing this then that will usually be your problem, rather than Shockwave itself.

Recommendations:
- If you have a secondary partition, I would highly recommend installing Zero Hour and Shockwave there, as you shouldn't experience any of the permission issues you would experience when installing into C:\. Installing outside of Program Files is an acceptable alternative as well.
- If you have the spare disk space, a backup Zero Hour folder is recommended.

If you experience any issues with installation or launching please post here, and I will try to help you. In most cases a screenshot of your Zero Hour folder is very helpful, however it is not required.

Alias
SWR Support
stevensamypp
I'm getting an error when launching, the Zero hour graphic pops up, as though I were launching regular zero hour, then it gives me an error saying to insert the correct DVD and restart the application. I can run regular Zero Hour just fine.

Alias
You've installed correctly, which is good.
It's strange that Zero Hour is acting like that, Shockwave does not change the Zero Hour executable so I'm unsure why your normal ZH doesn't whinge about the disk while Shockwave does.

I would recommend to just rename the .gib files to .big and launch straight from the Zero Hour shortcut. (You'll also need to enter the Data/Scripts folder and rename those files for the AI to work).

Alternatively, you could attempt to find a no-CD for Zero Hour, however by law am I not allowed to help you with that.
stevensamypp
Thank you very much for the help! Changing the .gib to .big has let me run the game by launching Zero Hour. AI works fine in challenge mode without changing anything in the data/scipts folder though.

Edit: So how do I need to rename the data/script files to get AI to work in skirmish mode?
Alias
Well the AI will still work without changing anything, you will just be stuck with ZH AI instead of the improved Shockwave AI.
Killer Instinct
I've tried everything. I have a clean install of Zero hour, because I installed the game just to play this mod. I tried the script fix, but then I have an "error 5: unable to copy Install_Final.bmp to Install_Final_Original.bmp".

I then renamed the two files and this time, it seemed to work for the first 5 seconds, until the same error came up in a different kind of window. When I went back to my directory, the script fix disappeared, and the files that I renamed went back to its original. I can run the original game however, and it automatically runs with the shockwave mod. But I cannot play skirmish because the AI doesn't do anything. I want to play with the new AI while at the same time not using the stupid launcher. It worked fine with the launcher used in shw 0.951, and all the files that the mod needed to install was already installed using the actual installation files instead of the launcher changing files automatically. I think that's the problem with the new launcher compared to the old one. I can wait for a patch that installs all the files the 1.0 launcher wants to install, if there ever will be a patch. Windows 7 definitely does not like programs changing files or adding files automatically.
Alias
There will be a patch that (should) fix most of these issues.

Okay, if you're launching manually you may as well just move the Scripts folder out of the Data folder. Stick it in your documents or something, just somewhere where the game can't access it (if you do want to go back to vZH you'll have to move it back).

Also make sure all of the files beginning with an exclamation mark all are .big files. If you wouldn't mind a screenshot of your Zero Hour folder would be nice.
bartpp7
Ok now when ever i start the mod it crashes , the smaller tital window comes up and then crashes ive done a complete clean reinstall and same resolts anyway to fix this.

i use win7 so im un sure if it has naything to do with that?
Alias
Can you post a screenshot of your Zero Hour folder.
stevensamypp
QUOTE (Alias @ 25 Nov 2010, 21:28) *
You've installed correctly, which is good.
It's strange that Zero Hour is acting like that, Shockwave does not change the Zero Hour executable so I'm unsure why your normal ZH doesn't whinge about the disk while Shockwave does.

I would recommend to just rename the .gib files to .big and launch straight from the Zero Hour shortcut. (You'll also need to enter the Data/Scripts folder and rename those files for the AI to work).

Alternatively, you could attempt to find a no-CD for Zero Hour, however by law am I not allowed to help you with that.

I was a little unsure what I was supposed to rename these files to, any help?

Alias
If you're still running it like before and running it manually, just move those files somewhere that isn't that folder. Since you've now said it crashes, something must have happened. Does it still work if you run from the Zero Hour shortcut?
bartpp7
Ok heres my ZH folder without SW
bartpp7
Ok now i just a unistalled generals ZH reinstalled it , installed Shockwave and Nothing it crashed again at the shockwave start up image again , i've tryed everything i can think of and nothing seems to work, any ideas guys?
Alias
Does regular Zero Hour work?
stevensamypp
QUOTE (stevensamypp @ 29 Nov 2010, 7:01) *
I was a little unsure what I was supposed to rename these files to, any help?


Didn't know if you missed this post. What was I supposed to renamed the data/scripts files to in order to have AI working the way it's supposed to for SW?
bartpp7
Ok well ive got stuck in an unexspected turn of events now both generals and zero hour have stoped works wich sucks and i can't seem too fix the problem, and yes i know you probly can't give me any info on how to fix the prob but i've given up i've unintalled an reinstalled and i have the TFD version so no patching up needed so i think im stuffed sad.gif
Alias
QUOTE (stevensamypp @ 5 Dec 2010, 13:12) *
Didn't know if you missed this post. What was I supposed to renamed the data/scripts files to in order to have AI working the way it's supposed to for SW?
Just move the Scripts folder out of the Zero Hour directory.
Danz Q
QUOTE (bartpp7 @ 5 Dec 2010, 3:57) *
Ok well ive got stuck in an unexspected turn of events now both generals and zero hour have stoped works wich sucks and i can't seem too fix the problem, and yes i know you probly can't give me any info on how to fix the prob but i've given up i've unintalled an reinstalled and i have the TFD version so no patching up needed so i think im stuffed sad.gif


Hey bartpp7! Have you tried some of the advices in this topic http://forums.swr-productions.com/index.php?showtopic=2091 ? When your installation is clean and ok the Zero Hour Data folder might be the cause.
bartpp7
I've fixed my problem it turns out the Zero hour data folder was marked as Read only stupid me LOL
Bob
Okay,

I have had the same loading problems file script error. I tried everything and then I noticed that the Data folder was marked read only. I unchecked it and it worked although I got the serious error upon exiting the game. Tried restarting and got the same script error message. I went back to the data folder properties and it was set to read only again.. I hope that there is a fix for this..Say there is...

Bob
Alias
Thread updated for 1.1.
Bob
I just moved this from main support forum. with an update of information.

I have just reinstalled Generals and Zero Hour, Patched both. and DL Shockwave 1.1. Installed it. I get this message everytime I try to start game: THE APPLICATION FAILED TO INITIATE PROPERLY (0xc0000135). CLICK OK TO TERMINATE.

Waht I have done so far:
I made sure Zero Hour folder and all subfolders are not set to read only.
I used run as administrator. (Although I do not get a choice, My main login is already selected)


I have read in the forums and cannot find a fix.
My OS is XP.

I was just able to get Shockwave to work by double clicking: shw_cnr.exe. It is running without the launches of course. Does this help to narrow done the problem?
dava
The ShockWave Launcher needs the .NET Framework to run correctly. Your Error sounds like that you haven't installed the Framework yet. -> http://www.realtyware.com/support/error-me...rly-0xc0000135/

Get the Framework and try it again. I think that will work smile.gif here's the link: http://www.microsoft.com/download/en/details.aspx?id=21
Trooper425
Hey all. I recently decided to start up SW again (and try adding some other mods too). I've never had any problem that I couldn't find a fix for before, but now...
I'm currently running Windows 7 x64. I installed TFD and SW, but couldn't get SW to work. I uninstalled SW, reinstalled Zero Hour, and tried that alone. Still no luck. When I run ZH it starts fine, it brings up the loading screen, but crashes after a min. It reverts to the TFD menu, rather than the desktop, and displays no error message. I've tried unchecking "read only" on the Zero Hour Data folder, but it always reverts to "read only". Finally, if I try to run ZH with either XP service pack, it crashes and this time displays the traditional "serious error" message and reverts to the TFD menu. I've scoured the forums here, and the C&C support forums, and have found no help.
Alias
Are you sure you're installing into the correct directory?
Trooper425
The SW installer originally wants to install to the TFD folder (as opposed to the Zero Hour folder). I don't think SW is the problem though. I can't run Zero Hour straight up.
Alias
In that case I'd suggest doing a full wipe of all Generals/ZH stuff and do a complete reinstall (and do it in a different directory too, just to be sure).
Trooper425
Alright, I totally uninstalled and reinstalled TFD. Now I get the classic "serious error" message when I try to start Zero Hour.
Trooper425
Alright, I found a solution to the "serious error" that is working well so far: http://www.geekstogo.com/forum/topic/15639...zero-hour-prob/
I doubt ShockWave will have any issues now.
jordie323
whenever i launch mine it says encounted serious error seriour errors can be caused by virus........ ive run virus scan but still not work dry.gif
GamerX
Sorry for the bump but I've got a problem while trying to launch Shockwave.

This is the error I get. I've got no clue if I have ZH Reborn mods since I haven't played Generals & ZH in a while and found out about Shockwave few days ago (Found the link of forums in readme). I'd be happy if someone could know how to fix this lol.
Thanks in advance.

P.s. I get this after running Shockwave Launcher > Start

If you think you can fix it via Teamviewer, contact me:
Email: gamerxownz@hotmail.com
Facebook: https://www.facebook.com/nikola.purisic
IRC: irc.crrpg.com, channel: #GamerX
MARS
Looks like one of those standard ZH errors. Most of them can be fixed using the following method:

1. Uninstall ZH and delete the entire ZH folder
2. Reinstall ZH into a new, clean folder and apply patch 1.04
3. Reinstall mods and apply mod patches if necessary

The mods you find on this website should be compatible with each other, meaning you can have them installed at the same time. We're not giving any such guarantees for non-SWR mods though.
GamerX
QUOTE (MARS @ 8 Dec 2011, 22:46) *
Looks like one of those standard ZH errors. Most of them can be fixed using the following method:

1. Uninstall ZH and delete the entire ZH folder
2. Reinstall ZH into a new, clean folder and apply patch 1.04
3. Reinstall mods and apply mod patches if necessary

The mods you find on this website should be compatible with each other, meaning you can have them installed at the same time. We're not giving any such guarantees for non-SWR mods though.


Ok, thanks a lot!
Where should I find the patch?
MARS
Try C&C Files.
Damo
I keep getting this error when I try to run C&C Shockwave 1.0.

The game is patched to 1.04 aswell so I dont think thats the problem.
Im trying to play the game on a Acer Aspire 8930G laptop but it dosent have a problem running any of the other C&C games.
Damo
QUOTE (Damo @ 10 Dec 2011, 13:27) *
I keep getting this error when I try to run C&C Shockwave 1.0.

The game is patched to 1.04 aswell so I dont think thats the problem.
Im trying to play the game on a Acer Aspire 8930G laptop but it dosent have a problem running any of the other C&C games.

Ignore that, the game had downloaded the 1.04 patch but not installed it properly, My fault guys, Sorry.
The game works fine now, thank you for the awsome addon/mod
de_llamaman
im only able to play in windowed mode as all other incarnations of the application throw up access denied windows weather tried in the launcher or from the zero hour folder
running windows 7 64bit
similar issues on other machines

reinstalled several time on different hard drives and have run out of ideas
help
General_Kirov86
Greetings, dear friends! I apologize to bother... :-)

I apologize in advance for the style of presentation. I am writing you from Russia and not very good at English. So I write with google-translator and therefore may write with grammatical and semantic errors. I must say that I am a very long time searching the Internet the answer to my question, but did not find one. The fact is that in our country C&C: Genarals game is not very popular, so I checked in with you and beg you to help me than anything.

My question is this:

I installed the game yesterday Genarals Zero Hour and my favorite mod Shockwave on a netbook. And when i start mod, I saw this great war video: http://www.youtube.com/watch?v=cvuhRh0hr1A (it kind of is called "shellmap" or "shell maps") I loved it! So I decided to install the game and the mod also on your PC. But when I installed the game and the mod on the PC, it is very sad. Since I have not seen this movie script. Instead, the screen was just a simple cover image / screen (http://img821.imageshack.us/img821/6089/5890507cc12e.jpg)

The same system (Win7 Pro x64). The same game (license). The same mod. One and the same version. The result is different ... ;-(

Once again I ask you roscheniya if this issue has already been discussed, but Help me please.

*update*

My issue/problem was resolved.. cool.gif I launched the game in Windows XP Service Pack 3 compatibility mode. Very tired while searching for a solution. It would be nice to add it to the FAQ. Since in the present most people use Windows 7 & Shellmap may does not work just as I have. Good luck! ..

I found it here: http://www.tomshardware.co.uk/forum/107125...-playing-movies
Pickysaurus
The shell map does not work correctly on x64-bit versions of Windows 7.

Карта оболочка не корректно работать на 64-разрядных версиях Windows 7.
General_Kirov86
Pickysaurus
May be... But in my case it work 100% correctly and i not detected any bugs/glitch or computer slows when shell map playing. Looking shell map about long time all over again (i tested and played for about a week.). Maybe I just got lucky? Who knows, who knows...))

In any case, thank you for responding!..
The_Hunter
Running the game in windows xp compatibility mode has solved this problem for several users.
soldierkahn
just in case noone has posted this specifically, I was having an issue launching the Shockwave mod when using with the CNC The First Decade set.

Originally, i assumed the default location to be installed would be in the "C:\program files\ea games\Command & Conquer: The First Decade\" root folder but when this is done, you will receive the "you installed to the wrong directory moron" message (no its not offensive, i appreciated the message). Through many attempts at trial and error, I finally set the install directory to:

"C:\Program Files\EA Games\Command & Conquer The First Decade\Command & Conquer™ Generals Zero Hour"

Once I installed in THIS folder, the mod works flawlessly. Like i said, im not sure if anyone has posted this, but i was unable to find anything when searching around that pointed me to the correct directory. So i wanted to have at least one post giving others some help in caxse they were getting frustrated as well. Sorry if its a double post. And by the way, a huge thank you to the creators of the Shockwave mod because it is single handedly the best version of the game ive ever played, shouldve been created this way from the begining!
Emin96
i have one question if i download shockwave and rotr at the same time will give me problem like: lags, mismatch, seriosly error please can anyone answer this question?
Azak
Hello. I bought command and conquer generals zero hour on origin as was wondering what file folder to install the shock wave mod in in. I tried once before and got the folder wrong and had to start reinstalling it. Can you help?
WIGSTA

Hey guys,

I just purchased a new 8.1 windows 64 PC and totally forgot how to load the whole thing from scratch.
Will it work on windows 8.1? is there 1 link I can click that will download all I need in one hit?

Much appreciated any help given.
Ven0mGamerX
Hi SWR Productions,

I recently got hold of Generals again, and I purchased the Ultimate Collection off of EAs Origin, so the game was patched to 1.04. however, when I try to install it works perfectly, but I still get the "You installed in the wrong folder, Moron!!" easter egg you guys have for us.

Please kindly assist.
Kalga
QUOTE (Ven0mGamerX @ 28 Nov 2014, 17:58) *
Hi SWR Productions,

I recently got hold of Generals again, and I purchased the Ultimate Collection off of EAs Origin, so the game was patched to 1.04. however, when I try to install it works perfectly, but I still get the "You installed in the wrong folder, Moron!!" easter egg you guys have for us.

Please kindly assist.


Hope this helps: http://forums.swr-productions.com/index.php?showtopic=5297
Jimb011
I dont know if this belongs here but here's the story. I recently found my old dvd of Command and Conquer generals deluxe edition which includes the zero hour expansion. Unfortunately the cds did not work. I talked to Origin and they provided me with digitized copy. I soon found a mod called Shockwave and wanted to try it out through origin. Unfortunately after installation the Vanilla game overrides the mod. I looked into other forums and found this quote:


QUOTE
So you have brought C&C The Ultimate Collection and realized that you can't get any mods to work (because EA is full of s--t). There's a simple way to fix that...
For C&C 2, C&C 3, RA3:

1. install the fixed launchers : Commandandconquer.com Never mind that link, not everyone can see it, try this one instead:Bibber.eu

2. Install Desura on your computer & get a Desura account (of course almost everyone who plays mods (beside me apparently) already got that part).

3. Download the mods that you want to play from Desura.

4. Play the mod(s)

For C&C General & ZH

1. Same as above.

2. Download whatever mod you want to play.

3. If mod has installer, launch it but make sure that the directory path leads to C&C Generals/ZH folder in Origin games rather than EA games or other things.
3.5. If mod does not have installer, simply put the files where they tell you to (still somewhere in the folder Origin games in C-drive, actually this way can be done without needing to install the fixed launchers. Note that this method can only accommodate one mod at a time.)

4. Play the mod(s).

For RA2:

I have no idea how to get mods to work for that. There's apparently something missing in the original files or something...



As you can see it referrs to Desura. However I don't understand how to do this process. when it says download whatever mods you want from desura; I ask my self where or how? If anyone can give me a simplified translation of this or a more detailed process I would appreciate it. thanks.
kapul
Hello,
I'm running windows 8, ZH running ok, Shochwave installed ok (folders, names, files, ...) when I launch shockwave (as an admin), it opens a menu with "launch, windowed, etc, ..." when i click on "launch", it seems to go then crashes with a error message "seriuos error ... " // NO other mods installed.

I've read the topics around here and it seems to be a compatibility problem between windows 8 and the shockwave.
Note : I can't choose any compatibility lower than windows xp (service pack 3).

One thing i haven't done is to install shockwave as an admin.

Other than that ZH perfectly running (french) and Command and conquer also perfectly running.

Kapul

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.